FAQ

What browsers are supported?

TeamSense has been tested on the following browsers and versions with no issues:

  • Chrome 47.0
  • IE version 11.0
  • Firefox version 44.0
  • Safari version 9.0.2
  • Edge version 20.10240 - Note that rendering problems have been reported with earlier versions